Alpha Developers Network

Guest


Author Topic: Alpha Five and QuickBooks  (Read 681 times)

0 Members and 1 Guest are viewing this topic.

viret56

  • Guest
Alpha Five and QuickBooks
« on: October 26, 2011, 08:09:01 AM »
I am writing an application which needs to access QuickBooks data in our company file (read-only).  I am using QODBC on the development computer as well as the production server.  I defined a named connection string for use on the A5W page. I debug the page and the connection is made within about 3 minutes. The page then finishes with the expected results, including the data from QuickBooks. I published the entire site to Local Webroot on my development machine (where I am running the debug from). When I try the page in question, the page executes up to the connection statement, then waits for the connection object response. I have waited up to 30 minutes with no response. It appears the app server is simply waiting for the connection object response and none comes.  The results are the same when accessing the page published to the production server.

I do not know why communication is breaking down between Alpha Five and QODBC on the server when it works in debug.  Does anyone have any suggestions?

I have now started to look into using the QuickBooks SDK directly with xBasic (as I have done using PHP).  Has anyone done this successfully?  Could you point me to some example code to get me started?

Charles Parker

  • Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
    • NWCO PRO
  • Real Name: Charles Parker
Re: Alpha Five and QuickBooks
« Reply #1 on: September 29, 2013, 01:46:46 PM »
Hopefully you figured this out by now - if you did could you comment? I would like to know more about what you are doing to make it work , what data are you connecting with? Are you simply importing records into your app and therefore your database?
Having done nothing in life, what would we have to remember?