• Welcome to International Application Developers Network. Please login or sign up.
January 19, 2021, 07:01:51 pm

Internal Server Error

Started by r.gamble@morrow.com, October 27, 2020, 07:13:13 am

0 Members and 1 Guest are viewing this topic.


I thought I'd follow this up real quick. After working with Alpha support for a couple days, they sent me some specific, temporary hotfixes to find out where the problem was happening. They weren't able to reproduce the problem but were able to track down the location in my code that was causing the issue. It turned out that Alpha itself was having trouble with the size of an onclick event for a checkbox control. Apparently, the size was around 4K. Their suggestion was that I put the code into a function and then just call the function in the onclick.

I have since gone with their suggestion, but initially, I went into the onclick code and removed blank lines, comments and a couple console.log calls. This cut the code in about half. As soon as I published those changes, it started working right and has been fine. Just to be safe, I created the function and call it from the onclick code. Both solutions worked.

The gentleman I worked with was Terry Smith and I was very happy with his work on this.


Hello -

I'm wondering if anyone can tell me anything they've experienced with an Internal Error 500 referring to  the script error in CompileStringTemplate() line:16.

We are getting this error sporadically in a single grid component. Usually if we close the error page and reopen, it is successful. It appears to be coming from the Alpha code but I'm assuming I'm doing something in my XBasic that is triggering it. By the way, we are using Alpha integrate with IIS.

It seems to be getting through all my startup code like OnGridInitialize, onSQLCountQuery, onSQLSelectQuery, etc as I've put logging throughout.

I've enabled Request Failed Tracing in IIS and when the problem occurs, it logs a whole bunch of "The specified network name is no longer available" errors I've attached an image on the error and the Request Failed Trace log in case it helps at all.

Very difficult to trace this problem to anything specific in XBasic...

Thanks for any help there may be on this